Lokale Gruppenrichtlinie kopieren

Ich habe gerade etwas einen PC für einen besonderen Aufgabe vorbereitet, dahbe habe ich mit dem Gruppenrichtlinien Editor, doch sehr vieles verbogen. Um bei einem späteren Neu Installieren des Rechners, schneller zu sein, ist es möglich diese Richtlinien zu kopieren.

Es gibt einen versteckten Ordner unter

C:WindowsSystem32GroupPolicy

Den Inhalt weg sichern und einem anderen Rechner rein kopieren, Neustarten und fertig!

Offline Dateien und MyDocuments auf dem File Server

Probleme und immer wieder Probleme

Ach wie schön.

Folgendes Problem gibt es hier schon eine ganze Weile.

Auf dem File Server liegen normalerweise die Daten der Benutzer. Meistens so server1home$%username%
Mit Windows Vista/7 passiert auf dem File Server folgendes
server1home$mydocuments

Die Verzeichnisse scheinen umbenannt worden zu sein.

Ein Anzeige Problem laut Mircosoft, schau ich auf dem File Server per Powershell nach, so stimmt die Ordner Struktur.

Stimmt so leider nicht ganz, die Offline Dateien von Windows 7 kommen hier mächtig durcheinander.
Abbhilfe schafft hier wirklich nur die Desktop.ini zu sperren.
Es ist laut Microsoft ein Bug http://support.microsoft.com/kb/947222

Es bietet sich die Lösung Nr. 3 an

Sehr geholfen hat mir dieser Link!

http://www.edugeek.net/forums/windows-server-2008/53755-home-folders-renames-my-documents.html

Hier wird noch beschrieben wie es per Powershell zu lösen ist

http://blog.salamandersoft.co.uk/index.php/2010/09/how-to-stop-home-folders-being-renamed-documents-in-the-network-share/

Selbst in einem Technet Blog, fragte man sich was hier passiert.

http://blogs.technet.com/b/asiasupp/archive/2010/12/14/windows-7-folder-redirection-rename-the-home-folder-in-quot-my-documents-quot.aspx

die anmeldung des dienstes gruppenrichtlinienclient ist fehlgeschlagen

Welch tolles Problem,

gruppenrichtlinienclient

nach etwas suche kommt man auf zwei Ergebnisse.

Passwort zurücksetzen und oder das Profil am Rechner neu erstellen.

Wieso das ganze passiert, kann einem niemand so genau sagen.
Das ist wohl der größte Ärger.

Im KB Artikel http://support.microsoft.com/kb/947215
Steht zwar man möge doch das Profil nicht von Hand löschen, dies habe ich aber nicht gemacht.

Mal sehen ob die Tage nochmal so etwas auftritt.

Advanced Format

Ich schlage mich gerade mit dem Advanced Format bei Festplatten rum.
Früher war es so, ab 1 TB gab es Platten mit diesem Format. Jetzt ist es so, dieses Format ist für Festplatten unter einem TB, nun auch zu haben.

Hier steht im Detail genau worum es geht

http://en.wikipedia.org/wiki/Advanced_Format

Dell bietet dazu eine gute Übersichtsseite und Lösungsansätze.
http://en.community.dell.com/techcenter/enterprise-client/w/wiki/deploying-dell-systems-with-advanced-format-hard-drives.aspx
HP bietet auch Hilfe an
http://h10032.www1.hp.com/ctg/Manual/c02691731.pdf

Ein ganz nettes Tool, das einem Übersicht verschafft.

Disk Alignment Test, Advanced Format Hard Drive Check

Sogar ein VB / Powershell Script bietet Dell an um zu überprüfen ob alles richtig paritioniert worden ist.
Problematisch ist bei der ganzen sachen Symantec mit Altirirs. Die dortige Windows PE Umgebung ist auf Version 2.1.
Laut Microsoft muß man mindestens Version 3 einsetzen mit KB Patch http://support.microsoft.com/kb/982018 um richtig Partitionieren zu können. Ab PE 3.1 ist alles kein Problem mehr. Dort sind alle notwendigen Patches vorhanden.
Symantec ist erst im Herbst 2012 dazu in der Lage, eine Windows PE 3.x zur Verfügung zu stellen.

Für alle die nicht warten wollen, gibt es hier schon einen Lösungsansatz.

http://www.symantec.com/connect/forums/winpe-30-31

Bedenkt aber es gibt keinen Support von Symnatec.

Wir haben hier gerade verschiedene Lösungswege im Ansatz. Wenn ich eine Lösung habe, update ich den Artikel hier.

*update*

So wir haben eine Lösung für unser Problem. Endlich
Folgendes ist zu tun.

Beim partitionieren ist darauf zu achten, diskpart mit dem Befehl clean auszuführen.
Danach die Partition mit diskpart align=1024 einrichten.

Hier ein kurzes Beispiel wie so ein Diskpart aussehen könnte


list vol
select Volume 0
assign letter o noerr
list vol
sel disk 0
clean
rescan
list disk
sel disk 0
create partition primary size=152600 align=1024 noerr
sel par 1
active
assign letter c noerr
sel disk 0
list vol
exit

Im BIOS von RAID auf AHCI umstellen.
Danach stimmt das Alignment. Wer sicher gehen will kann noch den Hotfix von Microsoft installieren. http://support.microsoft.com/kb/982018
Ich habe einige Benchmarks durch geführt mit ATTO. Es kostet zwischen 10 und 15 MB/s beim lesen und schreiben, wenn der Patch installiert ist.

*update2*

Hier noch ein weiteren Hinweis. Wenn das Alignment nun stimmt, ist ganz wichtig, den richtigen Treiber zu installieren!!!! Dies schon während der Installation.
Der Storage Treiber für AHCI sollte von diesem Jahr sein und mindestens Version 9.6 sein.
Besser gleich Version 10. Genannt als Intel® Rapid Storage Technology F6 Driver Diskettes
http://www.intel.com/p/en_US/support/highlights/chpsts/imsm
Der Treiber wo Windows mitbringt ist nicht in der Lage dazu. Treiber ist ca. 300 KB groß und beinhaltet folgende Dateien

F6Readme.txt
iaahci.cat
iaAHCI.inf
iastor.cat
iaStor.inf
iaStor.sys
license.txt
TXTSETUP.OEM

Windows 7 booten ISCSI die zweite

Hier mal ein Update

Ich bin weiter daran über ISCSI zu booten. Es gibt schon Fortschritte.

Man nehme eine Intel Karte. Intel Karten können von einem ISCI Target booten.
Die Karte kostet keine 30 Euro und läßt sich dementsprechend umkonfigurieren. Ich habe länger danach gesucht bis ich drauf gekommen bin. Dies ist ein sehr einfacher weg. Konfiguration ist im Boot ROM der Karte, während des Bootvorgangs ctrl+d drücken. Hier kann alles eingestellt werden, was fürs verbinden des ISCI Target notwendig ist.

support.intel.com/support/network/adapter/1000ctdesktop/

Dabei braucht man noch ein paar Tools und muß von DOS aus den PXE Boot ROM gegen den ISCI Boot ROM, austauschen. Dies geschieht ohne Probleme über die Intel Tools.

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21151

Ladet euch die PREBOOT.EXE runter und entpackt sie.
Wenn die Datei entpackt ist findet Ihr unter PREBOOT/APPS/iSCSI/DOCS/install.htm die Anleitung wie Ihr die Karte von PXE auf ISCSI ROM umflasht.
Dies kann jederzeit rückgängig gemacht werden.

Unter PREBOOT/APPS/iSCSI/DOCS/windows_iscsi.htm#2008 findet Ihr die Anleitung, falls kein ISCI Laufwerk angezeigt wird. Wie der Treiber hinzugefügt werden kann.

Leider bringt dies bei mir keinen Erfolg und mir wird kein ISCI Laufwerk angezeigt.
Ich bastel hier mal die Tage weiter

http://konkretor.blog.de/2011/03/29/windows-7-booten-isci-10910018/